Trying out Windows 7 Release Candidate – Part 1

Windows 7 RC desktop with example of provided wallpaper

Windows 7 RC desktop with example of provided wallpaper

Part 1 – Intial Installation

I decided to give Windows 7 RC a go since it has been generally well received in beta and the RC was just released the other day.

To give you my perspective I use a Dell Inspiron 1520 laptop running Windows Vista Home Premium as my main system. It uses a Intel Core 2 Duo (T7250) processor running at 2GHz, with 2GB of RAM. There is a 250GB HDD and the graphics are provided by an Nvidia GeForce 8600M GT mobile GPU.

After I downloaded the RC ISO image from Microsoft and burned a bootable DVD, my first tactic was to try it out in a virtual environment. I was slightly nervous about trying Win 7 on my “main” PC and I wanted to minimise the chances of a major catastrophe. So after a quick bit of research I downloaded and installed Sun Microsystems’ VirtualBox software. It was very easy to install and start up and I had a virtual version of Windows 7 running in less than an hour, from start to finish. My first impressions were positive. It was like a spruced up version of Vista. That is supposed to be a compliment. Vista has had a lot of bad press since it was launched. Most of this seems to have been because of compatibility problems, lack of driver support (at least initially) and not really because of the OS itself. Yes, the obtrusive User Access Control (UAC) screens caused annoyance, but could be turned off. It certainly looked nice with the Aero graphical flourishes and a useful search (at last) as part of the Start menu.

Well Win 7 has all this but has refined it a bit more and removed some of the annoying features of Vista. I’ll go into the details of my first impressions in a moment. However I found found there were general speed issues with running Win 7  in a virtual environment. I could not stream music or YouTube videos smoothly either. My broadband access is marginal at the best of times but the virtualisation process seemed to add an extra overhead that killed the experience for me.

So, I decided to take the plunge and do a direct install to the hard disk. This is where I encountered some problems…

Disk Partitioning

First off I needed to clear enough space. I had about 80GB free on C: but it wasn’t clear how much I would need for Win7. One guide said 16GB was the minimum but I was sure that if I was going to carry out a useful trial I would need a lot more than this – for some document storage, program installation and especially to try out the new Virtual XP Mode – more of which later.

I have a external 300GB HDD that I use for backing up, and a lot of the files on C: were already duplicated there. I did some major spring cleaning, nuked a whole bunch of stored stuff I really didn’t need, and ended up with 100GB free space. I decided to dedicate 50GB to the new partition for Win 7.

I followed the instructions at Lifehacker to shrink the existing partition in order to make room for a new one for the Win7 installation. Unfortunately they didn’t account for Dell’s weird disk partitioning structure. Dell, like a lot of OEMs have a separate partition containing utilities to restore your PC to factory condition, including an image of the factory state. Dell also have an additional extra hidden partition containing files for their “Media Direct” option. This is a separate bootable partition deicated to playing media files without having to boot up the full Windows OS. It is accessed by a dedicated hardware button on the keyboard. The problem is, this meant the default structure of the hard disk is one “system” partition (C:), a “restore” partition (D:) and two extra hidden ones (one of which is an “extended” partition).

The bottom line is that you are only allowed 4 primary partitions per HDD (or 3 primary and an extended which can contain further logical partitions).

I also encountered problems shrinking the main C: partition as the built-in Vista Disk Managment utility would not do the job. In the end I solved then problems in a rather convoluted way. I first defragged C: – the built-in Vista defrag seemed to take forever, so I downloaded a 3rd party free defrag tool from Auslogic. This completed the job in about 20 minutes. I used 3rd party partitioning software (Paragon Partition manager 9 SE) from a magazine cover disk, to shrink the C: partition to leave 50GB unused space. This took a long time because files needed to be moved during the operation even after the defragmentation. Then I had to sacrifice the 4th (extended) partition which was used for Dell Media Direct, and turn this into a 4th empty primary partition of 50GB to install Windows 7 into.

This all was quite nervewracking, and I wasn’t sure at each step whether it would work, but in the end, although it took some time it went smoothly. I ended up with my Dell Restore partitions intact (for use to get back to normal if it all goes pear-shaped), my original Vista still working albeit in a smaller C: partition, and a nice blank E: for Windows 7.

Then after making sure the BIOS was set to boot from DVD/CD before HDD it was simply a case of inserting the bootable Windows 7 RC DVD and rebooting. The Windows 7 installer ran and after about 30 mins with only a couple of prompts Windows 7 RC was installed along with Vista in a dual boot configuration.

Initial Setup

After the installation was complete the OS was working surprisingly well. However there were a few features that still needed updating. The screen resolution was wrong for the widescreen aspect of my monitor, and the default display driver did not give other options. The Nvidia graphics card was not recognised. I was also not connected to the internet. Trying to scan the hardware for any other problems there was a “base hardware driver” that was not present and since I was still offline it could not be found. I didn’t have any anyvirus software, and the Action Centre kept nagging about that.

First thing then was to connect to the wireless router. The router was immediately recognized so it was simply a case of entering the WPA encryption key (a labourious task since in my security conscious mode I had chosen a random 63 alphanumberic string…now, where did I keep that scrap of paper with it on..) and it was off. Then I ran Windows update and there were about half a dozen updates to download. One of these fixed the Display driver and downloaded the Nvidia configuration utility, and another was the “base driver” (whatever that was).

After that I was basically good to go. I needed to download a few core utilities before I could really feel at home:

  • Firefox
  • Xmarks (used to be Foxmarks)
  • Noscript
  • Hyperwords
  • Spotify (I had no access to my music library so I needed some entertainment!)

Go to Part 2 – UI changes and useability

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: